Need help understanding your bill?
tphipps's profile

New Member

 • 

3 Messages

Wednesday, March 22nd, 2023 12:12 PM

How to prevent iMessage activation activating roaming DayPass

I travel internationally almost constantly and keep my AT&T eSIM on my phone but turned off when overseas, as I have local SIMs in two other countries where I spend much of my time. I turn on the AT&T eSIM while overseas just to receive web login verification (e.g. 2FA) SMS from my bank, credit card and other services. 

It seems that as soon as I turn on the AT&T line while overseas, the $10 DayPass is activated immediately, even though I don't sent a message, make or receive any calls. From poking around a little, it seems that the iPhone upon seeing a new phone number being turned on is sending a silent SMS behind the scenes to a US number in order to "Activate iMessage" on the new phone number. This SMS (which I didn't send myself) is triggering the DayPass. Therefore, it's costing me $10 for each day that I turn on my US line while overseas even though it's only on for a few minutes and just to receive a SMS from my bank.

1. Is there a way to disable the iMessage activation message being sent by the iPhone as soon as the line is turned on overseas?

2. Is there a way to configure my AT&T account to not activate the $10 DayPass for this (behind the scenes) SMS send?

The only solution I have so far is to disable AT&T DayPass on the line before I turn on the eSIM while roaming. However, this isn't a great solution as I sometimes travel to countries where I need the DayPass and I don't want to forget to turn it on. I'm also guessing (but haven't verified) that without the DayPass, I'll be billed for a single outbound roaming SMS each time I turn on the line.

Surely someone has hit the same issue? It's driving me nuts being charged $10 to login to online banking while overseas!

ACE - Sage

 • 

116.9K Messages

1 year ago

Or disable iMessage?  You can unregister and turn off iMessage on your phone. If it's only iMessage that's triggering the charge. 

There's no reason you can't send regular SMS and MMS from an iPhone.  No guarantee that won't also trigger the automatic addition of international day pass (sigh)

Use over wifi calling.  You should be able to use your Us number for free back and forth between the USA and to receive two Factor text messages on your US number.  Phone/sim in airplane mode, connected to wifi.   There are a handful of countries which don't allow Wi-Fi calling, so it would not work in those countries

New Member

 • 

3 Messages

1 year ago

Thanks @formerlyknownas for a very thoughtful response. Some comments / responses:

1. I use iMessage extensively, both in the US and when travelling, so disabling it overall isn't going to work. I configure it to send and receive from my Apple ID email address as well as my US and non-US numbers, and it is totally fine as long as I activate each number on the cellular network every month or so, which is fine by me. It would be great if I could somehow disable iMessage just for my US number while I'm turning on the line to receive an OTP. But I don't see any way to do that. I guess I could disable iMessage totally while receiving the OTP, but that would cause it to re-send the registration SMS once I enable it again, but I guess I could ensure the AT&T line is disabled then. 

2. Sending regular SMS would definitely trigger the day pass, unless I'm very careful to use only my non-US number, but that defeats the whole purpose of using iMessage, so this is also a non-starter. 

3. Wi-Fi Calling - now that's an interesting idea. I was under the impression that it worked only for voice calls, but what you're seeming to imply is that if I disable the AT&T eSIM, ensure I have a WiFi connection, put the phone in airline mode and then enable the AT&T SIM and make sure WiFi calling is turned on, then it will register with AT&T AND be able to receive SMS messages via WiFi? That would be a fantastic solution. I'll try it out tonight, but please let me know if I've misconstrued what you're suggesting.

I guess my ultimate solution here would be either for Apple to use something other than sending a (silent) SMS to activate iMessage, or at least to prompt me before sending such a message and allowing me to cancel. I do get the "Do you want to enable this number for iMessage" prompt, but it seems that pops up AFTER it has sent the verification SMS, so even if I reply "no", the activation SMS is already sent. Bah!

ACE - Expert

 • 

64.7K Messages

1 year ago

I’m pretty sure activation of iMessage is done via data usage, not by some silent SMS message. Do you have data roaming turned off?

New Member

 • 

3 Messages

1 year ago

Thanks for the reply @sandblaster. I do indeed have data roaming turned off. 

iMessage activation works by the phone sending a SMS message containing a unique code to +447786205094. If you Google that number, you'll see lots of gory details on how it works. It seems that Apple-partnered carriers whitelist that number and don't charge for SMS sent to it, and AT&T seems to be doing the same. However, it still triggers the DayPass activation, which seems to be an oversight.

If I turn on the AT&T eSIM while overseas, with mobile data roaming turned off, within 10 seconds or so, I get the DayPass welcome message, which I can only surmise is triggered by AT&T seeing the outbound silent SMS to the iMessage activation number and having it activate the DayPass even though billing for messages to that number is whitelisted.

ACE - Expert

 • 

64.7K Messages

1 year ago

@tphipps Well, you learn something new every day. I had never heard of that. In any event, it would be the carrier your ATT esim roams on that would be reporting the sent SMS message which in turn triggers the day pass charge. Since you don’t disable iMessage, I would presume the SMS message is not actually activating iMessage (since it was never disabled) but rather reporting the phone number is now reachable through a different carrier. So, perhaps if you were to edit the iMessage send & receive settings to exclude your ATT phone number, perhaps that SMS won’t be sent. Just a thought.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.