Hurry! Find the perfect gift today! Everyone gets our best deals on any smartphone!
The Samsung Galaxy S23
EXCALIBURf's profile



10 Messages

Thursday, October 1st, 2015 6:04 PM

Weird ten-digit number attaches to email texts


I have been having this issue for awhile now. I get email messages from my bank and other companies through text messaging. Every time I receive a message this number is attached to it starting at *** and incrementally goes up from there per email message. If I delete the messages that has the ***, and up. It just starts all over again from 78. Why this is an issue for me is because I like to have an organized messages with contact info and contact pictures assigned with each sender. I can't do this if the message number keeps changing. I tested that if you use the email address that AT&T uses to send text messages to cell phone * it gets that number attached to it. If I get a email address using * it is not affected and I can see the email sender address that was sent from, and able to save the contact email in my contacts and have all messages grouped with whatever contact photo to go with it.

Here is a snapshot of the message:

[Edited for privacy-please do not post personal or unique information such as but not limited to full names, employee ID numbers, email addresses, phone numbers, account numbers, etc.]

I hope someone has some answers why this number gets attached and if there is a setting to change this to the senders email address versus a number that changes all the time.


I have the Samsung S4 Active (SGH-I537) running Lollipop 5.0.1.

Thank you!


Mike F.


Community Support


15.2K Messages

8 years ago



AT&T offers a great Messaging Preferences website to manage your and email addresses, create an alias, block incoming messages, manage email delivery controls, and set up block and allow lists.


It sounds like the issue you’re running into is correlated with the character limit, and the website allows you to make changes to that as well. There will be instances where an email message may not be compatible with the text message feature, but changing your settings should help to accommodate your needs.


Here’s the link to the Messaging Preferences website:


Hope this helps!




10 Messages

8 years ago

Hello, I treid to change the setting for email but nothing has changed and I am still getting that weird number attached to all email text messages. That website really doesn't have much of any settings so I changed the number of segments  from 5 to 10.

Not finding what you're looking for?