The Samsung Galaxy S23
dbrawson's profile



1 Message

Wednesday, June 26th, 2019 5:09 PM

New Galaxy S9 stuck trying update software to latest baseband version

Just purchased a new Galaxy S9 and transferred all of my info from my old S8 phone using Smart Switch.  I went to the settings to Check for Updates, and it said an update was available, but it got perpetually stuck trying to update it resulting in frequent notification interruptions saying software update was in progress or would retry.  I am on the latest version of Android, but it looks like the baseband version is a couple of versions behind (see attached picture).  It says I am on G960USQS3CSAG (I believe the latest is  G960USQS5CSEA ).  After a few days of frequent notifications that the phone was still trying update software, it now says software is up to date; however, I am still on an older baseband version. It doesn't appear the update was successful, and I still get notifications every now and then when connected to Wifi that it is attempting an update.  I have tried wiping system cache, starting in safe mode, restarting -- pretty much everything suggested on this forum and elsewhere aside from a full factory reset (which I would like to avoid since I now have everything set up and customized). 

Really frustrating.  Any ideas?

Screenshot_20190626-114156_Settings.jpgScreenshot_20190625-105643_Software update.jpg

2 Attachments

Accepted Solution

Official Solution


Community Support


215.6K Messages

4 years ago

Hi @dbrawson


Thank you for reaching out to us today. Unfortunately, the next step would be to backup your data (go to: Settings > Accounts and Backup > Backup and Restore) and then do a full factory reset.


Darais, AT&T Community Specialist

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.