Gifts that connect us - Get Free Galaxy Buds FE - Black with your purchase of a qualifying Samsung smartphone, today, Online Only!
You can also get the Samsung S23 FE & iPhone SE for only $0.99 a month!
The Samsung Galaxy S23
jarce729's profile



2 Messages

Thursday, October 27th, 2016 3:54 AM

Can't receive pictures if Advance Messaging is Turned On for Both Parties



I'm having issues receiving pictures that was sent when Advance Messaging is turn on. We have tried turning Wi-Fi Off, tried turning Advance Messaging just on mine OFF, and tried turning the other parties Advance Messaging OFF but we can only get it to work if both parties have it OFF.


The weird thing is the other party can receive pictures fine from me but when they send me a media then I cannot view it. The other party can also send and receive pictures from other people who has Advance Messaging ON perfectly fine.


So I might be thinking it's my device or something in my settings. Other functions of Advance Messaging works (like seeing when the person is typing, message delivered and read, etc) not just sending pictures.


Any IDEA? Phone in question is an Samsung GS6+ and the other parties phone is a Samsung GS7e



Accepted Solution

Official Solution

Community Support


224.8K Messages

7 years ago

Hello @jarce729!


I am so sorry to hear that you are unable to receive pictures when you have Advanced Messaging on! I totally understand any frustration, and I know that Advanced Messaging is a super cool feature to have! I will be happy to help!


Since you did the software update that provided this new feature, have you tried clearing out the message threads between the contacts you are trying to receive pictures from? If not, I would give this a try first!


Also, I recommend clearing the cache for your Messages app! You can do this by:

  1. Accessing your Settings from the drop down menu
  2. Scroll over to the Device tab
  3. Tap Applications
  4. Select Application manager
  5. Scroll down to Messages
  6. Click the Storage option
  7. Hit the Clear Cache button
  8. You also have the option to Clear Data if you don’t mind deleting your current text messages, or if you have them backed up to restore later


Let us know how that goes! Thank you and have a fantastic day!


Demetria, AT&T Community Specialist



2 Messages

7 years ago

Thank you! Clearing the cache and data worked for me. I completely forgot about that one!


Thank you again!

Not finding what you're looking for?