Let AT&T help you elebrate your dad with Father's Day Gifts that connect us.
Troubleshoot your device issues
cathyrowekamp's profile

Tutor

 • 

4 Messages

Wednesday, November 11th, 2015 3:38 PM

ATT UNITE Netgear 770s WiFi No Battery Error

My only internet access is the ATT Unite wi-fi hotspot.  From the first day we got it the Netgear 770S operated flawlessly, no problems.  Then about a year into the 2-year contract this device is no longer viable.  It started with a No Battery error.  I visited the Netgear forums to see if anyone else had the same problem and sure enough, I'm not the only one.  Removing the battery and keeping the power cord plugged in worked for a few days until a new battery was delivered, but we had to keep powering down and turning it back on.  The touchscreen was locked and unresponsive with the No Battery error.  

 

I was happy to find a new battery on Amazon and thought that would end the problem. Replacing the battery worked for one day.  

 

Like me, other ATT customers with the same problem have been told (a) replace the battery and when that doesn't work (b) replace the unit.

 

Seems to me any device attached to a 2 year contract should work for two years.  Not happy.

Accepted Solution

Official Solution

Community Support

 • 

15.2K Messages

9 years ago

 

Hello @cathyrowekamp

 

I’m sorry to hear about your Unite hotspot has been giving you problems.

Please click here and scroll down the left hand column and click on “Troubleshooting”  follow the steps to reset the device to factory settings.

Once that is complete scroll up the list and click on “System & Storage” and click on upgrade device software to ensure that no updates are available for the hotspot.

If there are please complete the updates and then power the device off/on. If this doesn’t resolve the issue and you have insurance on the device, please click here to file a claim with Asurion or you can connect with them @ 1-888-562-8662.

 

Hope this helps!

Gerald

Tutor

 • 

4 Messages

9 years ago

I have the same issue and it occured just outside the 1 year warranty.  I performed all steps including taking it to the ATT repair center where they said they updated the FW/SW.  I walked out and in 30 mins it was displaying the same message.  I was not able to go back as the store was closing and I had other errands to run.  I'd wish ATT would allow an upgrade as this is a defect in the product.  ATT Unite, Sierra Wireless, Netgear 770...its all the same, having the same defect.  I did not buy insurance.  The cost would be more than buying a new one in most cases. 

Tutor

 • 

4 Messages

9 years ago

So far the factory re-set has worked for me this evening.

 

If not try removing the battery, removing the SIM, wait about 10 minutes and boot up.

 

Don't waste your money on a new battery like I did until you try one of those!

Tutor

 • 

4 Messages

9 years ago

Sorry to say, two replacement batteries, factory re-set, removing the battery AND the sim card have not worked.  The unit continues to display the No Battery error; the battery must then be removed and replaced and the unit re-started in order for it to start working again.  It's defective, and if you check the NetGear forums there are many others experiencing the same problems.  The non-solutions provided by CS include all those listed above, then finally when none of them work for more than a day or two we are told to buy another unit.  

 

At this point with a year left on contract I'm not sure what we will do, but you can be sure we won't renew and will never buy another NetGear product again.

Contributor

 • 

1 Message

8 years ago

I fixed mine and here's how:

 

I used Electronic switch and contact cleaner and sprayed all the connections in the unit and on the battery and power supply plug (cable and aircard plug).  Then I remembered how most store employees handle the sim card. They touch the contacts with their fingers (not good) so I removed the card and cleaned it with the contact cleaner and a very soft cloth.  

 

I then let is set open with the card and battery out overnight (to be sure all the cleaner had evaporated). I reassembled it, pplugged it in and turned it on. It's been on now for over five hours continious.

 

Be careful you don't use contact cleaner that leaves a film. read the label.

Tutor

 • 

4 Messages

8 years ago

Okay, that's great but...  after doing everything possible suggested by customer service and seeing so many posts from people with this error, I am a bit skeptical this will provide a long-term solution.  Please post back in a week and let us know if it's still working.  If it does, you might want to check out the NetGear customer forum and let people know, there are many others having the exact same problem.  Thanks!

Contributor

 • 

2 Messages

8 years ago

I am having the same issues. Agreeing 2 1/2 hrs in phone w At&t. Factory reset working for a few hours and then same battery error message. This is my 2 nd box in 3 years.

Contributor

 • 

1 Message

8 years ago

My unit does not have a "Factory Reset" choice in the menu. Cleaned connections, took out SIM card and battery for 10 minutes. I will see how long this works. We do not need all the time, does it help if you turn unit off when not using?

Scholar

 • 

151 Messages

8 years ago

The device is only supposed to last a couple years, that's what ATnT told me when mine went out. Worked perfectly, and when it stopped working it was over. After troubleshooting on the phone with ATnT I had to buy another one, went refurbished on ebay, only saved me around $70, but still! Mine would boot up but could not be seen by my devices even though ATnT could see that it was turned on, which I thought was a weird problem. It's still the best option for my internet, and I really appreciate the constant reminder on the screen about how much data I've used.

Contributor

 • 

2 Messages

8 years ago

No Gerald those things did not help at all.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.