Check out AT&T's Valentine's Day Gift Guide for ideas & deals on the new Samsung Galaxy S23!
Get the myAT&T app
AZenobia's profile

New Member

 • 

6 Messages

Monday, November 7th, 2022 1:35 AM

Google Pixel 7 pro wifi calling

I recently purchased a Google Pixel 7 Pro but wifi calling is not working on this device. How do I solve this problem? It's important that this feature works because our cell reception here is atrocious and so the only way for me to make calls while at home is via wifi calling.

ATTHelp

Community Support

 • 

207.6K Messages

3 months ago

We'd love to help you with connecting your new Google Pixel 7 Pro to Wi-Fi calling, @AZenobia.

 

You'll need to check your Wi-Fi calling status on your device by doing the following:

  1. From the home screen, select the  Phone app.
  2. Select the  Menu icon, then select Settings. Select Calling accounts.
  3. Select SIM card (AT&T).  Select Wi-Fi calling
  4. Select the Use Wi-Fi calling switch to enable.
  5. Review the Important Information prompt, then scroll to and select Continue. Enter your emergency address, then select Verify address.

Also, when your phone is connected to Wi-Fi, Wi-Fi Calling is on, and a cellular connection is unavailable or poor, you'll see AT&T Wi-Fi Calling in the Extended Quick Settings to indicate that calls will be carried over Wi-Fi.

 

If you're still unable to connect, feel free to reach back out to let us know the error messages you're receiving. We'll be happy to continue to help!

 

Thanks for contacting the AT&T Community Forums. 

 

Lynn, AT&T Commuity Specialist

New Member

 • 

6 Messages

3 months ago

Yeah, did that. For some reason, it still doesn't work. Support said something about updating my software and that they would give that to me in the next 24 hrs. Hopefully, that will do the trick!  

New Member

 • 

9 Messages

3 months ago

I have the exact same problem. Pixel 7 Pro from ATT upgraded from an Pixel 6 pro from ATT.

Same feature worked on the pixel 6 pro in my bad att reception area. The settings for wifi calling migrated to the new phone, and I’ve gone back to verify, reset them and restart/power off the phone. I no longer get the indicator for a wifi call. Something isn’t right, maybe on the network side?

Edit: I know it is connected to wifi: When phone is connected to wifi, it works as before: Speedtest runs @ cable provider limit on wifi, it can not connect or run on cellular… not enough data signal for web, apps to connect or function

(edited)

New Member

 • 

9 Messages

3 months ago

”…Support said something about updating my software and that they would give that to me in the next 24 hrs….”

@AZenobia — did the software update work for you?

New Member

 • 

6 Messages

3 months ago

Sadly no. ATT says it's the phone's problem. Google says they'd let me return it... over a week ago, still locked out of being able to return it even though the request was made in during the return window. Anyway, my last ditch idea is to replace my SIM card. Heard some people had success in that. Crossing my fingers again.

New Member

 • 

9 Messages

3 months ago

Interesting! I'm having a hard time with the root cause being phone hardware... As far as I know the radios are identical to the pixel 6 pro that it replaced.

It makes more sense that it's a network configuration problem or something like a SIM card. Or I think it's more likely that it's a software problem, and wait ot out and it'll get fixed. I'm guessing we're not the only ones....

Thank you so much for responding, really appreciate it!

I'd appreciate it if you could report back on the SIM card work for you or not.

(edited)

New Member

 • 

9 Messages

3 months ago

.... I'd appreciate it if you could follow up on whether the SIM card fixed the problem or not, thanks again

ATTHelp

Community Support

 • 

207.6K Messages

3 months ago

We'd love to help you with connecting your  new Google Pixel 7 Pro to Wi-Fi calling, @Paul2bates

 

You'll need to check your Wi-Fi calling status on your device by doing the following:

  1. From the home screen, select the  Phone app.
  2. Select the  Menu icon, then select Settings. Select Calling accounts.
  3. Select SIM card (AT&T).  Select Wi-Fi calling
  4. Select the Use Wi-Fi calling switch to enable.
  5. Review the Important Information prompt, then scroll to and select Continue. Enter your emergency address, then select Verify address.

Also, when your phone is connected to Wi-Fi, Wi-Fi Calling is on, and a cellular connection is unavailable or poor, you'll see AT&T Wi-Fi Calling in the Extended Quick Settings to indicate that calls will be carried over Wi-Fi.

 

Let us know if this helps! Thanks for contacting the AT&T Community Forums. 

 

Mellira, AT&T Commuity Specialist

New Member

 • 

6 Messages

3 months ago

Honestly, I think you're right about it being a software issue but since AT&T and Google (I don't know which side is having the problem) don't want to admit it I have to play these games. I also love that the AT&T bot occasionally shows up and makes the same non-helpful comment over and over again. I will definitely let you know if the SIM card works!

New Member

 • 

9 Messages

3 months ago

@ATTHelp 

1-Per my earlier post, I did the steps. Multiple times, reboots or power off / on

2- "Also, when your phone is connected to Wi-Fi, Wi-Fi Calling is on, and a cellular connection is unavailable or poor, you'll see AT&T Wi-Fi Calling in the Extended Quick Settings to indicate that calls will be carried over Wi-Fi."

This is what is not happening, as it did on my previous 2 ATT pixels (5, 6 pro). I think something is amiss in the phone in the att network settings, possibly due to settings being migrated from pixel 6 pro to pixel 7 pro

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.