Let AT&T help you elebrate your dad with Father's Day Gifts that connect us.
russmcb's profile

New Member

 • 

4 Messages

Tuesday, March 28th, 2023 9:56 PM

Peer to Peer Networking Blocked (AP Isolation--?)

I'm getting error messages when setting up my (1st generation) Apple HomePods since my ATT fiber install with the Nokia BGW320-505 router. The messages say that peer to peer networking is not supported on my WiFi network.

I am getting mixed claims about whether AP Isolation is automatically active on the router as there seems to be no way to control this setting with the ATT router software. (On an unrelated note, it appears that I also can't kill the 5GHz signal when there is an extender on the network, which is a big bummer.)

I have activated a guest network and gotten things working when I connected the HomePods + AppleTV to that network, but the downside here is that the speed appears to be capped to about 1/10th the regular speed. So, there is some difference in AP Isolation (I'm assuming) between the regular and guest networks. Is it AP Isolation? If not, what is the difference?

I'm happy to add the MAC addresses to some kind of exclusion list or allocate permanent IPs to them, or whatever works to allow me to put my HomePods on the regular network so that they have peer to peer communication. Alternatively, maybe there's a way to give the guest network (which is password protected) full speed.

Bonus points if you can help me kill the 5GHz signal, even though I have an ATT extender on the network. 

Thanks.

Community Support

 • 

232.7K Messages

1 year ago

Hello, @russmcb! We understand that you are having trouble with setting up your Apple HomePods to your AT&T gateway.

 

First, we would suggest that you factory reset the AT&T gateway. This will reset the gateway to default settings and give you a good baseline to connect your third party devices. Since this will delete your custom settings, we recommend saving any of the settings you want to keep. 

 

  1. Press and hold the gateway Reset button for at least 10 seconds. If you let go before 10 seconds, the gateway will reboot, but won't reset.
  2. Wait until the gateway restarts and all the status lights are lit.
  3. See if the Broadband or Service lights are solid green. If so, the reset worked.

For your 5GHz signal concern, you may want to turn the band steering off. We recommend checking out this link that has  a response from our ace @tonydi for steps on how to turn the band steering off: http://sm.att.com/de1fb946

 

We hope this helps! 

 

Faith, AT&T Community Specialist

New Member

 • 

4 Messages

1 year ago

Thanks, we now have the factory settings to work from. 

1- The HomePods don't work anymore (as expected) because we've killed the guest network that I had them connected to (why they worked when connected to the guest network I do not understand). The goal, though, is to get them working WITHOUT putting them on the guest network because the speed is limited by 10X. Achieving the goal here, presumably, this requires enabling peer-to-peer networking (at least according to the error message from the HomePods).

2- Re. 5GHz, you sent me a link to a post about how to CHANGE THE NAME of the 5GHz network when my goal is to disable the 5GHz network entirely on the router. 

Any suggestions about achieving either of these two goals?

Thanks

(edited)

Community Support

 • 

232.7K Messages

1 year ago

Thank you for reaching back out, @russmcb!

 

Regarding your HomePods, the peer-to-peer networking feature may not be available on our AT&T gateways. You may need to set up a 3rd party router that has it, using IP Passthrough. Additionally, you may visit the Apple Forum Support  to see what other HomePod users are discussing.

 

The steps provided on the link on how to disable the 5GHz  band steering are pretty similar with how to change the name of the 5GHz network. 

 

Use the browser to navigate to http://192168.1.254, click on Home Network, Wi-Fi, Advanced Options and you can either change the name of the SSID for 5GHz or disable it.

 

We hope this helps.

 

Faith, AT&T Community Specialist

 

 

New Member

 • 

4 Messages

1 year ago

Thanks for the reply.

Are there any plans to implement peer-to-peer networking with a firmware update to the router in the future? I assume this is a pretty common need.

Alas, I can't disable the 5GHz when there is an ATT extender on the network, which there is in my case. I just get an error message when I try to disable it.

So, unless we are overlooking something, we are down to two options: 

1- get my own router which support P2P connectivity and connect my HomePods (and AppleTV) to it. 

2- put my HomePods and AppleTV back on the Guest network which apparently support P2P (??) but then I'm facing the 10X speed limitation problem.

Last question I guess since we haven't really been able to solve anything: Is there any way to turn off the guest network slowdown so that it operates at the same speed as the regular network?

Thanks.

ACE - Expert

 • 

35.8K Messages

1 year ago

, the peer-to-peer networking feature may not be available on our AT&T gateways.

Faith, would you be willing to put some more bars around that "may not"?  May not be if you have XXX model Gateway?  May not be if you have XXX configuration setting?   May not be if you are on different bands?  May not be if you're on firmware version XXX? 

Because, AFAIK, this should be working as long as not on Guest, or even with Guest if "Network Access" is set to  'Internet & Home LAN'.

Yes, you wouldn't have to question whether or not it worked if you got a third party gateway. 

New Member

 • 

4 Messages

1 year ago

Yeah, the only condition under which I can get things working is by enabling the Guest network with "network access" set to "Internet & Home LAN"... but then there's the speed limitation issue....

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.