Shop holiday gifts while you still can - Everyone gets our best deals on any smartphone!
RobertHueni's profile

1 Message

Saturday, September 2nd, 2023 5:23 PM

Issues with WiFi with Xbox Series S

Hi, I am having trouble connecting my XBox Series S to my internet. I have been having multiple issues for the past few days, and before this I haven’t had any issues.

  1. I will do the check internet in my XBox settings, and it will say I need to authenticate my MAC address. I have tried clearing the address, but that doesn’t fix it. I have tried to manually enter my MAC Address, but that won’t work either.
  2. When I run the internet test and the MAC Authentication screen doesn’t pop up, it instead says there is an issue with my IP address. I go through all the options, even manually re entering all of the IP stuff, but nothing changes.
  3. A few times, the internet test said that my XBox was connected to my WiFi, but I still can’t access any online features. I then run the NAT Type test, and it says my XBox isn’t connected to the internet.
  4. When on the Internet settings, on the right side it will say UPnP not available, Service info is unavailable, and NAT type is unavailable.

Apart from this, I have tried many times restarting my console and router.

Community Support


225.7K Messages

3 months ago

Hey @RobertHueni, we'd be glad to take a look into your Wi-Fi connectivity with the Xbox.



Firstly please ensure MAC Address is Authenticated:
• Ensure you are entering the correct MAC address of your Xbox. Double-check for any typos.

Then make sure your router is set to provide DHCP (Dynamic Host Configuration Protocol) to your Xbox. This should automatically assign an IP address. If DHCP is enabled but not working, you can try setting a static IP address within your Xbox settings, but ensure it’s within your network’s IP range.
For not being able to access any online features even after connecting to Wi-Fi,
Check if your router has UPnP (Universal Plug and Play) support, and make sure it’s enabled.
If UPnP is not available, you may need to set up port forwarding manually in your router settings. Consult your router’s documentation for instructions.

Additional steps to consider:

• Ensure your Xbox firmware is up-to-date.
• Try connecting your Xbox directly to the router via an Ethernet cable to rule out any WiFi-related issues.
• Check if other devices on your network are experiencing similar problems, which could indicate a router issue.

If these steps don’t resolve your issues, it might be worth contacting Xbox support for further assistance, as there could be specific network configurations or hardware issues that require professional troubleshooting.


let us know if these steps helps.


Sara, AT&T Community Forum Specialist


Not finding what you're looking for?