Find the perfect gift for the grad in your life with Graduation gifts that connects us from AT&T.
OrionPaxMTC's profile

New Member

 • 

11 Messages

Monday, February 21st, 2022 8:53 PM

Cannot access internal network resources - NAT Loopback

Cannot access my internal network resources, ie mydomain.com or my plex server after setting up my new AT&T Fiber service with the BGW320-500. Done lots of googling and found lots of other related articles and they either have a fix for it that doesn't work for me, ie using google DNS or setting up a second router (already done both of these things) or they say AT&T purposely doesn't support NAT Loopback (but why though?). 

My internal network is hooked up to a Unifi Gateway 4 Pro and DNS is pointed to google DNS. IP Passthru is setup on the AT&T GW with a static IP address pointing to my USG Pro 4.  I've done all the things that the internet says to do and it still doesn't work.  The only way I can access internal network resources is utilizing a VPN which isn't a long term solution or dropping off wifi and hot spotting my phone to specific computers/devices (roku). Which is also not a long term solution.

Would love some help here AT&T...I've called your support line and they thought I needed to know my username and password for the WiFI so they aren't going to be much help.

Accepted Solution

Official Solution

ACE - Expert

 • 

35.6K Messages

2 years ago

1) If you haven't already, do a Factory Reset on the Gateway.  That cures a host of ills.  Then you'll have to set it back up again.  Then reboot it.

2) Then turn off the Ubiquiti, give it a minute or two, and turn it back on.  It should try to get an IP address, and it should get the Public one.  If it doesn't, power it off and try again.  If it doesn't work after 3 tries of this, I'll try to think of something.

@tonydi , if you have any ideas... chime in. 

Community Support

 • 

232.3K Messages

2 years ago

Let's get you pointed in the right direction to address your NAT Loopback concerns for you, @OrionPaxMTC.

 

For further assistance with getting your home network working the way you want it to, we'd highly recommend you reach out to Hometech for further assistance.

 

Please don't hesitate to reach back out if you have any additional concerns and we'll be happy to help however possible. Thanks for reaching out on the AT&T Community Forums.

 

Jarod, AT&T Community Specialist

New Member

 • 

11 Messages

2 years ago

@ATTHelp please explain to me how "hometech" something that appears to be a warranty for electronics solves my problem of NAT Loopback and the inability for AT&T to allow it's customers to use the full capabilities of their home network? Not to mention you are trying to sell me a new service.

So yes, I have many additional concerns since you in no way helped me with my initial question, provided me with a useless link and wasted my time.

ACE - Expert

 • 

35.6K Messages

2 years ago

The BGW320 doesn't do NAT loopback.

However, your Unifi should.  Assuming that you've set up IP Passthrough in your BGW 320 to pass the public address to the Unifi, then you should be all set.

New Member

 • 

11 Messages

2 years ago

I have IP passthru setup on the BGW, configured for a private 192.168.x.x IP forwarding to my USG.  All of my equipment is behind the USG but it still doesn't work... Do I need to do something on the USG different?  Setup some sort of local DNS?  DNS for the USG is set to CloudFare (1.1.1.1) and Google as secondary (8.8.8.8) but still can't access internal domain of mycustomdomain.com

I agree I should be all set but I'm not so I'm guessing I'm missing something somewhere.

ACE - Expert

 • 

35.6K Messages

2 years ago

I have IP passthru setup on the BGW, configured for a private 192.168.x.x IP forwarding to my USG. 

Let's revisit this statement.  If IP Passthrough is correctly configured, then the WAN IP address of your USG will no longer be 192.168.x.x, it will be your public address.  Also note that the USG and the Gateway should be using two different private subnets on their "LAN" sides.

New Member

 • 

11 Messages

2 years ago

So the guide I followed had me set up IP passthru in this manner:

Setup 'Home Network' so this is a private network for 192.168.169.x

My USG is plugged directly into the AT&T GW and is assigned an IP in the 192.168.169.x network.  Set this as a static under IP Allocation tab.

Then under 'Firewall' tab...I have Allocation Mode as 'Passthru', Passthrough Mode is 'DHCPS-Fixed'

From the drop down Device List I select my USG's MAC address.

Save the settings and that's it.  My USG shows the PUBLIC IP for the WAN as 192.168.169.x IP address that it's assigned from the AT&T GW.

My Network behind the USG is 192.168.69.x  So they are not the same as with the AT&T GW.  However my WAN IP on my USG is not my public IP that the AT&T GW has.  I do not know how to make that happen.

I would appreciate any assistance you could give on setting up IP Passthru correctly if I have not done it right.

Thanks.

ACE - Expert

 • 

35.6K Messages

2 years ago

I assume the USG is still set to acquire its WAN address via DHCP from the Gateway?  Power off the Gateway and USG.  Power up the Gateway.  Wait a minute or two and power up the USG.  It should try to get its IP address via DHCP and be handed the correct Public Dynamic address.  If at first you don't succeed, try temporarily setting the WAN address of the USG manually, then putting it back to DHCP and trying again.  

New Member

 • 

11 Messages

2 years ago

I must be missing something...the USG does have a DHCP it's just from the private 'Home Network' that is set up.  Do I have to disable that and shut off DHCP in order for it to pull the WAN IP of the GW?  How does the GW assign it's public WAN IP to the USG?

ACE - Expert

 • 

35.6K Messages

2 years ago

It will originally DHCP and get issued a 192.168.1.x address.  Once you set up IP Passthrough to the MAC address, the next time the USG requests a new address from the Gateway it will be given the WAN address instead of the 192.168.1.xxx address.  You may have to wait until the initial lease expires. 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.