Get superfast AT&T Fiber internet
pnfiek's profile

New Member

 • 

2 Messages

Wednesday, December 21st, 2022 10:18 PM

TPLink Deco Mesh setup, which Passthrough mode option?

Hi there, I'm setting up a TP-Link Deco XE75 Pro with my AT&T Fiber 2GB service. I have the AT&T BGW320-500 gateway hardware.

I've followed the directions to change the passthrough, but then it asks for which passthrough mode and I'm confused. These are my three options:

DCHPS-Dynamic

DCHPS-Fixed

Manual

Which of these should I choose? Anything else I should know about in steps following this choice? Thanks!

Accepted Solution

Official Solution

ACE - Expert

 • 

34.3K Messages

1 year ago

DCHPS-Dynamic

Means that the first device to ask for an IP address via DHCP will be setup as the IP Passthrough device.  This is okay if you are sure that only your router can connect.  If you may want to connect with your phone or some other device, then this is a bad idea.

DCHPS-Fixed

Means that you specify the device that you want to be the IP Passthrough device from the Drop Down List.  The Gateway remembers its MAC address and any time that MAC address asks for an IP address, it will be treated as the IP Passthrough device.

Manual

Means that you will statically assign the WAN IP address, proper Default Gateway and Subnet mask to the WAN interface of your router so that it doesn't have to ask the Gateway for it.  The Gateway will just assume that you've done that and treat it as the IP Passthrough device.  This can be real useful if your router doesn't work with the Gateway's DHCP server well (some don't).  It can be a pain in the rare instance that your public dynamic IP address actually changes (which is nearly, but not quite, never).

ACE - Guru

 • 

9.9K Messages

1 year ago

I always choose Fixed, that way you're sure the BGW320 will always hand the public address to your Deco router.

New Member

 • 

2 Messages

1 year ago

Awesome, thanks! Sounds like fixed it is. That also would explain the dropdown list. Appreciate the quick help!

ACE - Expert

 • 

34.3K Messages

1 year ago

I used fixed until I had some unexplained dropouts that happened with a frequency pretty close to my IP Passthrough DHCP renewal period.  Then I went manual.  Loved it until I switched to fiber and got a new IP address and needed to manually reset the WAN and Default Gateway.  But that's the only time in years that my public dynamic has changed.

New Member

 • 

3 Messages

1 year ago

The passthrough mode you choose will depend on the configuration of your network and the requirements of your devices.

  • DCHP-Dynamic: This mode will automatically assign IP addresses to devices connected to your network. This is the most common mode used for home networks, and it is the easiest to set up.
  • DCHP-Fixed: This mode will assign fixed IP addresses to specific devices based on their MAC addresses. This is useful if you want to ensure that specific devices always have the same IP address, such as for port forwarding or other advanced configurations.
  • Manual: This mode will allow you to manually configure the IP addresses and other network settings for each device. This is typically used for advanced network configurations and may require more technical knowledge.

For your case, you should choose DCHP-Dynamic as this is the most common and easiest to set up mode. It will allow you to connect all your devices to the network and have them automatically assigned IP addresses.

You should also check the Router's documentation, to confirm the setup process, and check if there are any specific settings that need to be done.

Additionally, you should check if there are any settings on the AT&T BGW320-500 gateway hardware, that need to be configured in order to work with the TP-Link Deco XE75 Pro.

ACE - Expert

 • 

34.3K Messages

1 year ago

@Ramoss Your advice is general, not specific to IP Passthrough, and as such really doesn't belong here.  I'm leaving it for now with this caveat.

Contributor

 • 

3 Messages

7 months ago

Hi,

I'm trying to get IP Passthrough to work for my Deco AXE5400 mesh network. I reset everything earlier tonight to start over because the Deco network seems to drop the entire network every 7-10 minutes once I turn on IP Passthrough. Has anyone else had issues with this? I thought perhaps the issue was my gateway, as I had a Pace 5268AC which is quite old. I received a BGW302-505 over the weekend and just got it setup tonight, but still having the exact same issues with my Deco system.

I'm so fed up with it that I've initiated the return process and bought the ASUS ET8 mesh unit 2-pack, but I would love to know what in the world is causing my issues and am willing to troubleshoot accordingly.

ACE - Expert

 • 

34.3K Messages

7 months ago

The issue is likely that your router isn't successfully renewing the public IP via DHCP.  You can try upping the lease time on the IP Passthrough page to something more than 10 minutes (like a day) to give it more time to attempt the renewal and to make failures less frequent.  Or you can move to manual mode (statically set the WAN information on your router to what it's getting).  AT&T's Dynamic Public IP assignments are incredibly sticky.

Contributor

 • 

3 Messages

7 months ago

@JefferMC When I had IP Passthrough on DHCPS-Fixed, I did see that it's IP Address was the external IP address, but even when I upped the lease to 84 days, it was still dropping frequently.

I guessed at setting up manual last night and then updated the Deco settings with the appropriate values, but when I did that, the Deco loses the internet connectivity entirely. Admittedly, I am not sure which devices should be restarted after making these changes. The Gateway doesn't give an indication that it should be reset when changing IP Passthrough settings, so I have not done that. I have been restarting the Deco after making these changes to the Gateway and/or the Deco, though. I'm also not sure if there's a correct order of operations I should be following. Do I update the Deco to static IP and then turn on Manual mode for the IP Passthrough or do I turn on Manual IP Passthrough and then update the static IP info on the Deco?

Deco Static IP Settings
Internet Connection Type Static IP
[Dynamic IP, PPPoE, L2TP, PPTP, DS-Lite, V6 Plus, MAP-E(OCN) are also options]
IP Address Broadband IPv4 Address from Broadband tab on Gateway
Subnet Mask 255.255.255.0
Default Gateway Gateway IPv4 Address from Broadband tab on Gateway.
Primary DNS 8.8.8.8
Secondary DNS 8.8.4.4

Of course, after writing all this and testing again (I had put it in AP mode last night before going to bed because I was getting fed up and just switched it back to Manual), it appears the Deco has connection. Usually it takes a few minutes before failing, so I'll wait and see.

Could it also be that a device on my Deco is causing issues? Other than computers, phones, and smart speakers, I've got a few hubs for smart bulbs/switches.

(edited)

ACE - Expert

 • 

34.3K Messages

7 months ago

I think your subnet mask is wrong.  I think you want 255.255.252.0 (not 255.255.255.0)

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.