Get superfast AT&T Fiber internet
Curious_George's profile

Contributor

 • 

23 Messages

Tue, May 31, 2022 1:31 PM

BGW320-505 Gateway periodically drops many IoT Devices

Arrgh.  It just happened again.  I have U-verse Gigabyte fiber service.

Every week or two, my BGW320-505 does something and drops many of my smart home devices (thermostats, smart lights, smart plugs, etc).  If I'm lucky, most them eventually reconnect (over a day or two).  Sometimes restarting the gateway helps, but this time it didn't.  I had 20 fewer devices connected when I woke up this morning than when I went to bed last night.

Most devices if a power them off and restart them, they eventually reconnect, but that means turning of circuit breakers for wall switches.  It is maddening to have to deal with this a couple of times a month.

Contributor

 • 

23 Messages

2 m前

Same as this: https://forums.att.com/conversations/att-fiber-equipment/gateway-dropping-iot-devices/6192f2b955bc6123e7d05f3d

dave006

Scholar

 • 

3.1K Messages

2 m前

Have you split the Wi-Fi 5 and 2.4 GHz SSIDs?  The BGW320 is a Mesh Wi-Fi device so 3 (two 5 GHz and one 2.4 GHz) Wi-Fi bands share the same SSID be default.

Since you have so many IoT devices leave the 2.4 GHz SSID the same and move the 5 GHz SSID to a different Name and password. You can make the change here: http://192.168.1.254/cgi-bin/wconfig.ha

IoT devices are well know as not having the most complex Wi-Fi systems onboard so they don't as a general rule as a family of devices to support Mesh networks. Yes so devices are smarter than others.

That's an easy test and while you are at it check the uptime on your BGW320 to see the last time it was restarted at this link:

http://192.168.1.254/cgi-bin/sysinfo.ha

Dave

Contributor

 • 

23 Messages

2 m前

Thanks for the suggestion.  I will try it.  Of course AT&T warns me when I do that I shouldn't.  But I have read it elsewhere, so I will give it a try.  

I get it the IoT devices can be pretty dumb, but when the work for weeks then suddenly the network is a mess, I'm not sure they are the problem.  But if AT&T wants to say they don't support smart homes, I suppose they can go that route. (Sorry if I sound unhappy - my wife isn't happy that the internet isn't reliable).

ATTHelp

Community Support

 • 

195K Messages

2 m前

We're here to help keep you connected to your network, Curious_George!

 

The security of the AT&T Gateway can often conflict with IoT devices, which are smart devices that connect to other devices on or outside your network.

 

If you want to use your devices with your AT&T service, you will need to set up port forwarding on your AT&T Gateway. You can begin to start the process for setting up port forwarding for your TV by selecting the model of AT&T Gateway you have, and following the steps to change the configuration.

 

Let us know if this helps!

 

Donovan, AT&T Community Specialist

tonydi

ACE - Guru

 • 

6K Messages

2 m前

@Curious_George   Completely ignore the noise you just heard, that was ATTHelp Donovan blindly reaching into the grab bag of "solutions" they have and pulling out yet another completely irrelevant suggestion.  🙄

JefferMC

ACE - Expert

 • 

29.3K Messages

2 m前

The security of the AT&T Gateway can

I think you used the wrong "s-word."  I think you mean to start that sentence with "The stupidity..."

dave006

Scholar

 • 

3.1K Messages

2 m前

@Curious_George 

Since you have provided only very limited data at this point (which is expected) we start with the obvious swing of the bat to isolate your IoT devices first and then whenever there is a Wi-Fi blip they should just reconnect seamlessly without any action on your part.

but when the work for weeks then suddenly the network is a mess, I'm not sure they are the problem.  But if AT&T wants to say they don't support smart homes, I suppose they can go that route. (Sorry if I sound unhappy - my wife isn't happy that the internet isn't reliable).

Dave

Contributor

 • 

23 Messages

2 m前

I have connected my wife’s devices (laptop, iPhone, iPad as well as my devices to the 5-G, and at least for the short duration of the test, that is working fine. 

The 2.4G network is still acting up. I can’t connect my iPhone to it (Unable to join the network). Some, but not all IoT devices are connected and working as expected. 

I tried “Find the best channel” on the gateway. I forgot the 2.4 network and tried a clean connection. 

I appreciate your help, and I’m happy to provide more details if you tell me what would be helpful. 

I know to ignore the generic “help” from AT&T. 

dave006

Scholar

 • 

3.1K Messages

2 m前

The 2.4G network is still acting up. I can’t connect my iPhone to it (Unable to join the network). Some, but not all IoT devices are connected and working as expected. 

Why would you want to force your iPhone to connect to the 2.4 GHz network?

For the IoT devices with issues it would help to know what type of Wi-Fi connection they want. Set your 2.4 Ghz "Mode" setting to only the range for the IoT devices. Default on the BGW320 is G/N but you might want to try mode B/G/N.

You also want the 2.4 GHz bandwidth set to 20 MHz instead of 40 if you changed it from the default.

I would also hard code Channel 11 for the 2.4 GHz radio and start there if you need to change it go to channel 6.

All changes are made here http://192.168.254.1/cgi-bin/wconfig.ha the Advanced Wi-Fi settings page.

Dave

OttoPylot

ACE - Expert

 • 

18.4K Messages

2 m前

@Curious_George  FWIW, AT&T-supplied gateways, and pretty much any ISP-supplied gateway are lame. With my router, I just let my devices connect to whichever band they needed to and they all worked with zero issues. I have recently placed all of my IoT devices, which are pretty much all 2.4GHz on the Guest network, which does have a separate SSID/pw for a little bit extra security but I didn't have to. No pass-through, no port forwarding, none of that useless info from AT&T Help.

Listen to the suggestions from the members here and disregard AT&T Help.

Contributor

 • 

23 Messages

2 m前

Some of my IoT devices are 2.4GHz only, and they get their wifi information from the iPhone app, and the iPhone has to be connected to the 2.4 band.  If it is connected to the 5 band, the IoT device configuration will fail.  (This answers the question of why I would want to connect my iPhone to the 2.4 band).

As of this morning, the 5 band is still working great for all of my wife's devices, so she is happy.  But I still have a multitude of IoT devices that won't connect.  This includes 2 Honeywell Thermostats, 2 Lumary smart lights, a Treatlife wall dimmer switch, 2 Tasmota wall switches, a Tasmota smart plug, 1 Techin Smart Plugs, 2 Meross smart bulbs and a Meross wall dimmer switch, 3 Ring security lights and a Ring doorbell, Rachio Sprinkler, MyQ garage door hub and perhaps a few more. 

All of these were working fine until yesterday.   Now they won't reconnect.  I have tried restarting the gateway modem, turning off the power the the IoT devices so they will restart.  One device I reset to factory condition, but in its configuration mode, it won't connect to the 2.4 network.

I'm beginning to wonder if my 2.4 radio is having trouble.  But there are some devices that are connected: 1 Techin smart plug (twin of the one that is not connecting), 2 Honeywell Thermostats (I have a total of 4 for a zoned system 2 connect, 2 don't), 2 Kasa smart plugs, 2 Tasmota smart plugs.

I'm at a loss of what to try next.

(edited)

dave006

Scholar

 • 

3.1K Messages

2 m前

Let's backup a step here. Did you change the SSID of the 2.4 GHZ band or only for the 5 GHz band?

You should have left it alone to minimize changes since you were able to get your IoT devices reconnected and it only happened about 1 every 2 weeks.

OK your reasoning for the iPhone needing to be on the 2.4 GHz is driven by the need to use it to setup some  IoT devices via Wi-Fi and on the 2.4 GHz network.

Apple devices try to be too smart but you can for them to work the way you want them to.  First go into your Wi-Fi setting and forget the Network associated with this SSID name. You access this feature by selecting the Info button.

Then restart your iPhone. Yes physically restart, not Airplane mode or using the Control Panel to disable Wi-Fi and re enable it.

Then set your iPhone to connect to this 2.4 GHz band SSID and make sure to set Auto-Join to Off.

SSIDs and passwords can be tricky for may IoT devices. Don't have spaces in the SSID, SSIDs can be case sensitive to the IoT clients, and finally the password should be a string with no spaces and in the exact case as you setup in the router as you would match the case of the SSID.

Note: yes many clients are more flexible and more forgiving of any differences but it you are consistent it should always work.

Dave

Contributor

 • 

23 Messages

2 m前

Thanks @dave006 

I did NOT change the SSID/password for the 2.4 GHz band, only for the 5 GHz band (I cleverly added -5G on the end of the SSID name for the 5 GHz band that was previously used for both.  This is why I find it odd that the many devices that are not connecting to the 2.4 GHz bande are having trouble.  I didn't change anything with the devices or with the 2.4 GHz band setup, other than I did try the Find Best Channel button on the Gateway/router.  I'm wondering if it changed the channel and that is causing trouble for the devices.  But I have tried (on a couple of them), removing the existing connection information and trying to create a new connection to the 2.4 GHz network, to no avail.

I will tried rebooting the iPhone.  That yielded a new message that there were other devices trying to use the same channel and that I should reboot and let the router pick a new channel.  Of course I have rebooted many times lately, and it didn't solve the problem this time either.

(edited)

Contributor

 • 

23 Messages

2 m前

To continue this sad saga, I called ATT support.  I spent 3 hours on the phone with someone trying to troubleshoot the problem.  They insisted on returning to using the same SSID for 2.4 and 5.  It didn’t really make much of a difference, but I guess it was on their checklist and they couldn’t move forward unless we tried it.  At the end of 3 hours, they said they would send a tech, who is coming tomorrow morning.

JefferMC

ACE - Expert

 • 

29.3K Messages

2 m前

Thou shalt worship at the altar of Band Steering.  To deviate is to be lost.

Other than swapping out your Gateway, the technician is very unlikely to be able to provide much assistance.

Need help?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.