Hurry! Find the perfect gift today! Everyone gets our best deals on any smartphone!
What is happening with 3G?
JRush1's profile



1 Message

Tuesday, May 2nd, 2017 3:08 AM

Bridged Comacst Modem/Router to D-Link Router now MicroCell not working

New to Comcast as my IP,  bought my own Arris Modem Router with phone line ports, then Comcast loaded their firmware on to it so now logging in to it, it looks just like a Comcast router.  A little background, When I first set up Comcast gateway, I set the Firewall settings high can't remember the term or checked box.   What happened when I did it  though is that it blocked my Micro Cell from working, I changed it to a lower setting and then the Micro Cell worked fine.  Then I decided I wanted to use OpenDNS filtering service, which Comcast won't allow in the settings of Gateway  (modem/Router), So I bought a new D-Link  Model DIR655C1, switched the Arris/Comcast Gateway to bridge-mode, which then only gives one functioning Ethernet port, #1 port  (or so I was told)  That functioning Port , Port #1 hooks to the  D-Link router Internet Port.  I then have my MAC, Printer and Micro Cell all wired to D-Link router by Ethernet.  The Micro Cell is in the same spot when it was working with the Comcast Gateway,  all the lights show it's working fine and all cell phones can see it.  It's just won't allow a cell phone that is connected to the Micro Cell to make or receive calls.  This is similar to what happened when I set the Firewall setting to high on the Comcast router.  I searched the settings on the D-Link but can't find any where to reduce firewall protection, so it may be something else.    Thanks for any help, I'm by far an IT guy, but my wife thinks I am, so please help me keep the Lie going.

ACE - Expert


22.7K Messages

7 years ago

@JRush1 - you need to ensure that the router is configured to meet the minimum router settings as given in the setup instructions  and in my Tech Guide, which is a little more in detail or my blog (see links in my sig). There are four ports that must remain open at all times as well as IPSec Passthrough enabled and Block Fragmented Packets disabled. The modem has to be set to bridge mode and only one device, the router, is handling NAT duties.


The Arris modem/router sounds like it is a telephony router as well (you mentioned that it has phone ports). Those typically have default settings that can be incompatible with the MicroCell. Who knows what Comcast flashed to your router to make it look like a Comcast router. Comcast also offers their own VoIP service which may interfere with the MicroCell. Don't ask Comcast for MicroCell help because they will say it's AT&T's problem and be of no help at all.


I'm assuming that the power, ethernet, GPS, and 3G lights are all a solid green. Do any of your phones display the M-Cell alpha tag? Have you shut off your phones and then restarted them again? Sometimes the phones need to re-establish the MicroCell as being part of their cellular neighborhood.

Not finding what you're looking for?